can't access Compact Flash

USB Image Tool support forum
Post Reply
facuz
Posts: 2
Joined: Fri Aug 29, 2014 7:57 am

can't access Compact Flash

Post by facuz »

Hello,
i'm using this great tool for long time: normally i create backup-images of CompactFlash card and restore them when i need.
I do this through a USB multi-card reader and i never had problems until yesterday.
I always use CF of type "Innodisk iCF 4000, Wide Temp.Compact Flash, 2GB, P/N DC1M-02GD31W1SR" , or "DeLOCK 2GB", but from yesterday my supplier starts to give me another type of CF:
"Innodisk iCF 4000, Wide Temp.Compact Flash, 2GB, P/N DC1M-02GD31W1DB"
and i can not read or write it, the tool always give me the error Code 0: "Could not write to USB device (Code: 0)! Please close and open explorer windows for this device".

-There are no windows open for that device
-I'm using the same PC with the same OS (Windows 7 Pro 64bit)
-I already tried to disable the antivirus with no success
-I already tried to use another PCs: another Windows 7 Pro 64bit and also a Windows XP pro 32bit, with no success
-I already tried to use another multi-card reader, with no success

Apparenlty there are no differences between the old CF and the new one (only the P/N code is different) but i'm not able to do anything with this CF card and my card reader!

Even if i use diskmgmt.msc, i can see the Device but i can not format it! it says "I/O device error"

I really don't know what to do, it's a big trouble for me. :?

Please can anyone help me or suggest me something to do? :?:

Thank you,
Stefano
Alex
Site Admin
Posts: 267
Joined: Fri Jul 29, 2011 11:59 pm

Re: can't access Compact Flash

Post by Alex »

Hello,
Sorry for the late reply. Does this report a general problem with USB Image Tool or do you get the errors for these specific CF cards, even if you haven't used USB Image Tool for them? Do you have any issues with the old working CFs or are they still working fine?
facuz
Posts: 2
Joined: Fri Aug 29, 2014 7:57 am

Re: can't access Compact Flash

Post by facuz »

In the beginning the problem appeared only on this specific CF card, and not only using USB Image tool but with other tools and windows utilities too.
The old model of CF card had no problem.
Unfortunately after a couple of days the old CF cards have shown the same problem too!
So i started to think that the problem was not on the CF cards or on the softwares, but maybe on my PC or ... on the USB readers i tried.
Bingo.
I bought a new cheap CF reader and all works great!....for 3 days. Then no signal from it, no signal from my CF cards.
At this point i tried 4 different USB readers, and my question is: is it possible that all these USB readers are defective or broken?
The answer is YES, they are.
I didn't give up and i bought 2 new USB readers, one from S-tech adn one from Kingston: the first one is ok but is too fragile, and i think it will stop working soon :?
The other one from Kingston is great:it is more solid, it's faster 'cause it's USB 3.0, insert and remove CF cards is easier.
No more problems with new or old CF cards and USB Image Tool.
Sorry if i wasted your time, but it was a very unusual problem.I never thought that the cause could be in 4 different USB readers!
Thank you for your help.
Have a nice day.
Post Reply