Can't see restored image

USB Image Tool support forum
Post Reply
Posts: 1
Joined: Sat Apr 06, 2013 9:37 pm

Can't see restored image

Post by AreaMan »

Please excuse a really basic question. It's so basic I feel a bit shy asking, but here goes. If I restore an image to a USB stick, and it succeeds, there ought to be a readable partition on the stick, right?

More specifically, I have downloaded a SqueezePlug image from, the purpose of which is to create a bootable USB key containing a Debian install preconfigured to run SqueezePlug, a music server, on (in my case) a PogoPlug computer. I did the restore on my Win7 computer, as administrator, and I got the success message, but I can't get the pogoPlug to boot from the key. I know there could be any number of reasons for this, but I suspect the key because the pogoPlug doesn't appear to see it at all. It doesn't appear with fdisk -l. And if I stick it back into my Windows machine, it says I have to format it before using it. I might suspect a bad key, except if I do format it, - or if do a RESET in USB Image Tool, the pogoPlug and Windows both see it just fine. In any case, I've tried it on a two keys, multiple times, and get the same results. I've re-downloaded the image file too. Same result every time.

So, I'm new to this, and very new to Linux, but I'm pretty sure that a restored image of a bootable Linux image should appear to have a file system and some files on it. Am I right? Or does my problem lie elsewhere?

The follow-up question, if the answer is yes, is of course: what might be going wrong here? I'm running latest version (1.61) as admin, in device mode, putting a <4GB image onto an 8GB stick, with A/V off.

Thanks so much in advance.
Site Admin
Posts: 267
Joined: Fri Jul 29, 2011 11:59 pm

Re: Can't see restored image

Post by Alex »

Just tested the download myself. The Squeezeplug image contains a small (55 MB) FAT32 partition and a larger 3.1 GB Linux partition. When I write it with version 1.61 to my flash drive, I see the FAT32 partition as expected. Maybe your downloaded image is corrupt. Either check this with the hash values on the download page or use a Image viewer like WinImage/OSFMount to inspect the downloaded image file.
Post Reply